Centos7安装最新版Nodejs

使用yum install npm 安装的版本太老,所以尝试手动安装。 经过测试发现,node,npm,yarn版本必须配套一致,否则会出现很多问题。

1、下载

wget https://nodejs.org/dist/v8.11.2/node-v8.11.2-linux-x64.tar.xz

2、安装

sudo tar -C /usr/local –strip-components 1 -xvf node-v8.11.2-linux-x64.tar.xz

或者

sudo tar -C /usr/local –strip-components 1 -xzf node-v8.11.2-linux-x64.tar.gz

安装完之后需要重新登录或重新启动。

3、安装yarn

npm install –global yarn

分享到:更多 ()

留言板 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址